注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

天朝布衣田中码农参上

苦逼码农的点点滴滴,请多多指教!

 
 
 

日志

 
 
 
 

Eclipse不能启动提示Failed to load the JNI shared library错误问题的解决  

2017-09-28 10:13:21|  分类: JAVA |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
此问题一般是由于不兼容问题造成的,64位JDK搭配32位的eclipse,就会造成这个问题,所以要解决这个问题,请注意相应版本。
解决办法如下:
1)如果您同时安装了32位和64位的JDK,64位JDK配置在默认变量JAVA_HOME中,那么要让Eclipse用32位JDK启动,请修改Eclipse.ini文件,在OpenFile后加入两行:

-vm
D:/JDK32/bin/javaw.exe

这里的路径请按照您安装的32位JDK目录相应调整。
2)还有一个办法就是,直接将32位JDK的JRE目录放置在Eclipse目录下面也可以让Eclipse不使用默认的64位JDK启动运行。
相信在解决这个问题之后,各位其实也能够看出,如果系统安装了多个版本的32位或64位JDK,是可以让其各安其位,唯一的麻烦就在于,运行各种JAVA软件时指定要启用的JRE,当然您也可以通过修改JAVA_HOME及PATH变量来实现,虽然会有占儿麻烦。
  评论这张
 
阅读(0)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017