注册 登录  
 加关注
查看详情
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

天朝布衣田中码农参上

苦逼码农的点点滴滴,请多多指教!

 
 
 

日志

 
 
 
 

pip安装指定版本包问题  

2017-05-25 10:59:12|  分类: 服务器 |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
CentOs系统默认的Python是2.6,一般大家都会用yum update来将其换成2.7的,但是也有人在坚守,并不更新到最新版。主要是考虑到Centos6的源里很多软件包默认只认2.6……换2.7会有模块导入错误的问题。这样的话,问题也就来了,上次的文章《CentOs安装pip步骤与使用详解》已经谈起过pip的安装,如果安装默认的版本软件包,比如gevent,如果用最新版本,就不支持2.6,这特么就让人很尴尬了。
提示的错误信息很直接粗暴:

Exception: Please install gevent 1.1 for Python 2.6

pip安装指定版本包问题 - sinsunson - 天朝布衣田中码农参上
好吧,我们只能无奈地叹息下。如果实在不想升级到2.7,那么就使用如下命令来装gevent 1.1吧。

#pip install gevent==1.1

使用两个等号来指定包的版本……看起来好像很有道理的样子,让我们只能无言以对,总之问题暂时就这么解决了。虽然我们还是建议升级python到最新版本2.7会比较好。
  评论这张
 
阅读(3)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2018