注册 登录  
 加关注
   显示下一条  |  关闭
温馨提示!由于新浪微博认证机制调整,您的新浪微博帐号绑定已过期,请重新绑定!立即重新绑定新浪微博》  |  关闭

天朝布衣田中码农参上

苦逼码农的点点滴滴,请多多指教!

 
 
 

日志

 
 
 
 

HTML5 Shiv – 让该死的反人类IE系列低版本浏览器也来支持HTML5吧  

2017-05-23 10:47:01|  分类: JavaScript |  标签: |举报 |字号 订阅

  下载LOFTER 我的照片书  |
HTML5最近成了大热门,能做的事儿很多,最有效的就是语义化标签的应用,如果曾经在Chrome或者其他支持HTML5的浏览器上尝试过它的牛x,肯定就不会想再用别的啦。但是呢,万恶的IE系列低版本浏览器居然不支持HTML5,那要让其支持HTML5,就必须另想办法了。
html5shiv.js就是一套实现让ie低版本等浏览器支持HTML5标签的解决方案。源码地址:https://github.com/aFarkas/html5shiv。原理很简单,使用创建元素的方法【包括document.createElement和document.createDocumentFragment】,对当前页面不兼容的HTML5元素进行动态的调整,并且为这些元素提供最基本的样式。
使用起来也非常简单,只要把下面代码放在页面的head内即可。

<!--[if lt IE 9]>
<script src="dist/html5shiv.min.js"></script>
<![endif]-->

下面就是几个要注意要点:
1)请尽量使用min版本的js(压缩过的)以节省带宽和提高加载速度;
2)必须在body元素之前加载;
3)可以在CSS之前或者之后加载,但如果以性能考虑,CSS先于html5shiv加载会更好。
好了,拥有了这个,我们就可以尽享HTML5的乐趣了。


  评论这张
 
阅读(0)| 评论(0)
推荐 转载

历史上的今天

在LOFTER的更多文章

评论

<#--最新日志,群博日志--> <#--推荐日志--> <#--引用记录--> <#--博主推荐--> <#--随机阅读--> <#--首页推荐--> <#--历史上的今天--> <#--被推荐日志--> <#--上一篇,下一篇--> <#-- 热度 --> <#-- 网易新闻广告 --> <#--右边模块结构--> <#--评论模块结构--> <#--引用模块结构--> <#--博主发起的投票-->
 
 
 
 
 
 
 
 
 
 
 
 
 
 

页脚

网易公司版权所有 ©1997-2017